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Introduction to GFW Pro

BROWSER COMPATIBILITY: GFW Pro is compatible with the latest two versions of Google Chrome, 
Mozilla Firefox and Microsoft Edge. You must use one of these browsers in order to access Pro.

!

Global Forest Watch Pro (GFW Pro) helps you securely manage deforestation risks in commodity supply 
chains and investments. This guide provides detailed, step-by-step tutorials for using Pro, including 
instructions on how to:

• Create an institutional account and add individual users from your organization.
• Upload locations from your supply chain or investments that you want to analyze. You can add one 

location at a time or upload multiple locations at once. GFW Pro provides templates depending on 
the commodity and format of the locations you would like to upload.

• Create lists using your locations or datasets managed by Global Forest Watch.
• View detailed diagnostics for specific locations or a list of locations.

SECURITY: GFW Pro uses best-in-class security protocols for accounts, including rigorous 
password requirements and two-step verification to log in. GFW Pro will time out after 4 hours  
of inactivity. You will be automatically logged out of your profile and will have to log back in. 

PLEASE NOTE THE FOLLOWING: 

2

INTERNET CONNECTIVITY: A wired Internet connection with at least 10 MBPS upload and  
download speed is recommended. Test your speed here: https://speedtest.net. Avoid utilizing  
a VPN if possible.

NUMBER NOTATION: GFW Pro will automatically match the number notation format of your data 
with the language of your browser. Please keep in mind that your computer’s operating system will 
need to be set to a language that matches your browser language.

https://speedtest.net


Account Creation and Management



Create a New Account
To use GFW Pro (Pro), you will first need to create an account. Each organization is limited to one account. Account Administrators can 
add an unlimited number of user profiles within their organization’s account (see instructions on adding new users below).

Only account Administrators will follow these steps to set up a new account. Other users will be added to their organization’s account 
by their account Administrator.

1. Go to http://pro.globalforestwatch.org.
2. Click on “Sign up for access to GFW Pro.”
3. Enter your personal information and accept the terms of service and privacy policy. You must apply on behalf of an organization 

with an organizational email address. Personal email domains such as Gmail and Yahoo! will not be accepted.
4. The World Resources Institute will review all new account applications within two business days of submission.
5. You will receive an email with a temporary password once your account has been approved. Follow the instructions to log back in 

to My GFW Pro and reset your password. You must reset your password within 3 days, before your temporary password expires. 
 Note: If you have already created an account on GFW Pro and create another new account with the same email address, you will be able to  
        select an account to access during the login process.

6. The Pro log-in process uses two-step verification. Every time you log in to Pro by entering your user name and password, you will 
come to a verification screen prompting you to enter a token code. You may choose to use either emailed tokens for authentication 
or Google Authenticator. If you choose email authentication, a new code will be emailed to you every time you log in.  If you select 
Google Authenticator, download the app, and you will be prompted to enter the token provided in the app to log in to Pro.

KEY TERMS
Account: Every organization is limited to one main account on GFW Pro, but can add subsidiary accounts. An account 
can have an unlimited number of users. Each account has its own secure storage space – accessible only by users 
registered to that account.
Profile: Each individual user has a profile tied to an organization account. An individual’s information and any locations 
they upload are stored in their profile. Three permission levels are available to set users’  capabilities and access within 
GFW Pro. 

Manage an Existing Account

• Edit your organization’s information and upload or manage policy documents
• Add and manage users from your organization
• Connect parent companies and subsidiaries
• View all activity on your account in an activity log

As an Administrator, you can customize your organization’s account to best fit your needs in the following ways:

Edit your organization’s information
1. Go to http://pro.globalforestwatch.org. Log in to your account in the upper right corner and enter the token code sent to 

your email.
2. You will see different menu options at the top of the page: dashboard, locations, map, and profile. Click on the “Profile” tab.
3. As an Administrator, you will see “Profile Manager” at the top of your profile page. In the first section, you can view details 

about your organization. You can edit any field except the organization name, which is locked. You can also upload a policy 
document from your organization to reference in Pro.
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http://pro.globalforestwatch.org
http://pro.globalforestwatch.org


Add and manage users from your organization
1. Click the “Profile” tab. You will see a list of all users, including their access level and status (active or pending).
2. To add a new user:

a. Select “Create New.”
b. Enter the details of the user you want to add.
c. Determine and select the new user’s permissions level. See Appendix 1 for details on permissions.
d. Complete all mandatory fields and any desired optional fields and click “Save.” You will be directed back to your profile 

page.

3.     To activate a new user:
a. Once a new user has been added to your 

organization, their account needs to be 
activated before they can log in.

b. To activate their account, scroll down to 
the “Users” section of your profile page.

c. You will see the new user you have 
added, with status “Pending.”

d. Click on the user’s name. At the bottom 
right of that user’s profile page, click  
“Activate” to activate their account. Pro 
will then automatically generate and 
send an email to the new user with  
log-in instructions.

5ACCOUNT CREATION AND MANAGEMENT
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4.     To change an active user’s Access Level:
          a.     Click the “Profile” tab. 
          b.     Click the name of the user you would like to change.
          c.     Click the “Access Level” drop-down menu and select the desired
   level. See Appendix 1 for details on permissions associated   
   with each Access Level. 
          d.     You must be an Administrator to change Editor and Viewer access  
   levels. Administrator access levels cannot be changed. 
          e.     See the next section for instructions on how to deactivate all user
   types. 

Deactivating users and your account
1.     To deactivate a user:
          a.     You must be an Account Administrator to deactivate users in your account. 
          b.     Click the “Profile” tab.
          c.     Click the name of the user you would like to deactivate.
          d.     Scroll to the bottom of the user’s profile page and click deactivate. 
          e.     The user will no longer be able to log in to GFW Pro. Any lists the user uploaded will still be available to all Account  
   Administrators.

2.     To deactivate an Account Administrator:
          a.     An Account Administrator must email a formal request to gfwprosupport@wri.org. 
          b.     A GFW Pro Super Administrator  will respond within two business days with an email template. 
          c.     An Account Administrator must complete the email template and respond to gfwprosupport@wri.org to confirm the  
   request. 
          d.     All profiles, lists and locations the Administrator created or uploaded will still be available to all Account users. Any lists shared  
   with others in the organization will still be shared .

https://d1ps9kreypzu9a.cloudfront.net/Training%20Guides/GFW%20Pro%20Tutorials/GFW_Pro_UserGuide.pdf
mailto:gfwprosupport%40wri.org?subject=Deactivate%20Account%20Administrator
mailto:gfwprosupport%40wri.org?subject=Deactivate%20Account%20Administrator


Connect parent companies and subsidiaries
1. Navigate to the “Profile” tab.
2. Check the subsidiary box.
3. Enter the Parent Organization name.

View activity log
1. Navigate to the “Profile” tab.
2. At the bottom of your profile, you can view a record of 

all activity in your account by selecting “View Activity 
Log.”

Editors and viewers can also manage their profiles and edit some 
profile information by clicking on the “Profile” tab.

Editor and viewer profile management

• Editors and viewers can change the phone number, title,  

geographies of interest, commodities of interest, and 

second-level authentication preferences. All other fields are 

locked.

• Editors and viewers can change their password by clicking 

the “Change Password” button at the bottom of the “Profile” 

tab and following the on-screen instructions.

3.     To deactivate an Account:
          a.     An Account Administrator must email a formal request to gfwprosupport@wri.org. 
          b.     A GFW Pro Super Administrator  will respond within two business days with an email template. 
          c.     An Account Administrator must complete the email template and respond to gfwprosupport@wri.org to confirm the  
   request. 
          d.     All users and data will be securely saved in the account’s database on GFW Pro, but not accessible by any organizational  
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mailto:gfwprosupport%40wri.org?subject=Deactivate%20Account


Uploading Locations and Lists



In GFW Pro, you can add and create lists of locations you want to monitor or analyze from your supply chain or 
investments over time. You can add locations in a variety of ways.  Manage locations and lists by selecting the 
“Locations” tab on the top menu.

The “Locations” view displays Global Forest Watch-managed lists of locations, as well as any lists that you have 
uploaded. On the left-hand side, you can upload new locations and create lists. 
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Locations Introduction

Add One Location at a Time
1. Click the “Locations” tab. 

 Note: If you plan to add, delete or move a single location or multiple locations, please save a copy of the original list for your records.

2. Click “+ Add Locations” on the left-hand side. This will prompt you with an option to upload either a single location or multiple 
locations. In this instance, select “Add a Single Location” then click “Continue.”  
 Note: If you have not yet uploaded a file into GFW Pro, you can clik the “Add Locations” button in the middle of the screen to begin your first  
        upload.



8. You will have the option to select start and end dates or a time horizon for the location’s review period; as well as the option to 
add additional metadata to the location such as company policy ranking, risk level, certification and more. Depending on the 
commodity type, it might be useful to have this information associated with the location.

9. Once you are done filling out the relevant information, click “Save” to save the location, or click “Save and add another” to save 
the location and begin adding another location. If something is not filled in adequately, an error message will appear indicating 
the section that needs revision.

UPLOADING LOCATIONS AND LISTS 10

3. From here, you will be taken to a new page to add the location. Select whether you are uploading an investment in any  
commodity type or any commodity supply chain location, as well as the associated commodity type.

4. Name the location and either create a new list or add it to an existing list, then enter the location information using one of the 
following methods:
a.     Enter Address: Enter any street address.
b. Enter Coordinates: Enter latitude with a decimal value between -90.00 and 90.00, and longitude with a decimal value 

between -180.00 and 180.00.
c. Draw a Shape: Draw an outline of any area on a map. Click “Start Drawing’ to begin, then click on the map to add points to 

your shape. Connect the shape or double click to finish drawing.
d. Upload a File: Files can be up to 5 MB and can be uploaded in the following formats:

i. CSV or Excel.
ii. .Zip file containing a shapefile (.shp, .dbf, .prj).
iii. KML or KMZ.

 Note: You can only add your location to a list of the exact same template type or, if using a generic template, the same commodity type     

                 with the same location classification. For example, a soy supply shed can only be added to existing lists of soy supply shed locations.

Commodity templates:
• Palm oil mill
• Palm oil plantation
• Palm oil smallholder farm
• Soy silo
• Soy farm
• Beef slaughterhouse
• Cattle ranch
• Cocoa farm
• Other

Property: Farm or plantation

Supply shed: Sourcing area around a processing facility, storage facility or collection point

Administrative area: All countries, states, and sub-states worldwide

5. You will have options to customize your location further, including setting a sourcing distance around your location and 
selecting a review timeframe.

6. For Commodity uploads, select a location classification. Please note that location classifications will be pre-defined and not 
editable for certain commodity templates.

7. There might be one or two fields that are mandatory for each template, like ID or Company ID. Most of the remaining fields 
are optional.



Add Multiple Locations Using Excel / CSV Files
1. Look for “Download location upload templates” under the “Add Locations” button on the 

left-hand side bar.
2. Click “Templates”. 
3. From the drop-down menu, select and download the Excel location template that matches 

your data. For guidance on selecting the correct Excel template, see Appendix 2.
4. Complete the Excel template. For guidance on completing the Excel template, see  

Appendix 3. You can upload a maximum of 1,500 locations per Excel file. 
5. On the left-hand side bar, click “Add Locations”. Select “Add multiple locations” from the  

pop-up modal and click “Continue”. Select whether the location is an investment or  
commodity to begin uploading your completed template file. 

Step 1: Prepare to upload your template
a. Select whether you are uploading locations as a Commodity or Investment template. 
b. Select the commodity type that matches the template you wish to upload.
c. The type of location and commodity type MUST match the template you are uploading 

exactly, or Pro will reject the upload. 
d.     Click “Next.”

        Note: You must choose a commodity type 

before advancing to step 2. Remember, you 

can only upload one type of commodity per 

template for commodity locations. However, for 

investment locations, you can select ‘multiple’ 

as the commodity type and include various 

commodity types in the Excel/CSV file.
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10. To add another location of the same type, click next (if you chose investment, you’ll see “Next Investment.” If you chose  
commodity, you’ll see “Next Commodity.”) Click “Save” to save the location.

11. You will be navigated back to the Location page. A banner will appear at the top of the page to indicate that analysis of your list 
is in process. 
 
 
 
 

12. GFW Pro will then run an analysis of the location you have added. You will receive an email when the analysis is complete. You 
can view the analysis results in the “Locations” menu of the “My Lists” section.



Step 4: Correct and check your data

Step 3: Upload your template
a. To upload your file, either drag and drop it from your computer, or click 

“choose file” and select it from your computer. If the file you try to upload 
is unaccepted, you will be prompted to re-upload the file. Files must have 
less than 1,500 locations and be smaller than 5 MB. Accepted file types 
include: 
i. CSV or Excel.
ii. .Zip file containing a shapefile (.shp, .dbf, .prj).
iii. KML or KMZ.

a. If there are any errors in your file as it uploads, they will appear with a red exclamation point to the left of them. Look for cells 
highlighted red in your locations. Highlighted cells indicate a mistake in a cell. You can hover your mouse over the invalid cell 
and Pro will tell you what format is expected for that cell. 

b. You can update the locations with errors directly on GFW Pro by clicking into the cell that has the error and fixing its informa-
tion. 

c. You can toggle between “Locations with errors” and “All locations” to see which of your locations have errors, where the 
errors are in your locations, and to confirm that an error has been corrected and saved. Locations will move from the “Loca-
tions with errors” to the “All locations” tab in real time. 

d. You can also download the correct data into a CSV by clicking on the download icon.
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Step 2: Add additional attributes
a. On the second step of the upload process, you will have the option to 

add additional attributes to the location. Only complete these fields if 
the information is also in your template – all information must match 
the template you are uploading exactly. Once complete, click “Next.”

b. Click “Next.” Pro will perform an initial check on 
each column of your uploaded template to make 
sure it matches system requirements. Pro will 
display a message with any errors. If errors appear, 
you must fix the original file and re-upload it into 
Pro by following the steps above.



f. If you try to move on without fixing the errors, a pop-up asking if 
you are sure you want to continue will appear. You can proceed 
with the upload process with errors in your list. Any locations with 
errors will be discarded upon clicking “Submit” to upload the list. 

g. Once the validation step is complete, click “Next.”

Step 5: Save your data
a. To save your locations, you can create a new list with a name of your choice or add the locations to an existing list. You can 

only add locations to existing lists with the same commodity template format or with the same commodity type and location 
classification for the generic commodity templates. If you want to return back to a previous step in the upload process, click 
the linked steps on the left-hand side of the screen to review your work. Once complete, click “Submit.” 

c. GFW Pro will then run an analysis of the location you have added. You will be navigated back to the Location page. A banner 
will appear at the top of the page to indicate that analysis of your list is in process.  
 
 
 

d.     You will receive an email when the analysis is complete. You can view the analysis results in the “Locations” tab under the 
“My Lists” section. See more detail on Pro analyses here, or click here to learn how to monitor locations in near real-time.
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Add Multiple Locations Using a Shapefile, KML or KMZ file
1. To upload a shapefile, KML or KMZ file, you must already have the data saved in the appropriate format and template. Attribute 

field names must match the column titles in the templates listed on the Locations page, and include the appropriate fields in 
GIS software for shapefiles or Google Earth Engine for KML/KMZ files. 
Shapefiles and KML/KMZ files may be no larger than 5 MB to upload and include no more than 1,500 locations. Shapefiles and 
KML/KMZ files must be points or polygons — not lines.  
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a. Shapefiles
i. Shapefile templates are available or download from the “Locations” tab. Look for “Download location upload  

templates” under the “Add Locations” button on the left-hand side bar. 
ii.      Click “Templates” and select the template of your choice.

                  iii.     Complete the Shapefile template. For guidance on completing the Shapefile template, see here. 
iv.     See a guide to each template type in Appendix 2 to select the best one for your locations upload.
v. Download a sample shapefile for reference here.
vi. You must add all mandatory and optional attribute field names to your file, even if you do not populate those fields.
vii.     ArcGIS will truncate all attribute field names to 10 characters and replace any spaces with underscores. See all 

attribute field name constraints.
viii. You must meet all standard requirements for shapefiles created in ArcGIS.

b.     KML/KMZ
i. Create a Google account and visit https://www.google.com/maps/d/ 
ii.  Upload KML file to map.
iii.  Go to data tables. Make changes to field names by renaming in a table or editing attribute values. 
iv.  When finished, export the layer back to KML. 
v. Download a sample KML or KMZ file for reference here. See a guide to KML files.

Step 1: Prepare to upload your template
a. On the left-hand side bar, click “Add Locations” and select “Add multiple locations” from the pop-up modal.
b. Select whether the location is an investment or commodity and then click “Next.”
c. The type of location and commodity type MUST match the template you are uploading exactly, or Pro will reject the upload. 
d. Click “Next.”
                Note: You must choose a commodity type before advancing to step 2. Remember, you can only upload one type of commodity

                per template for commodity locations. However, for investment locations, you can select ‘multiple’ as the commodity type an

                include various commodity types in the shapefile/KML/KMZ file.

Step 3: Upload your template
a. Upload the shapefile or KML/KMZ file that you saved to your computer by clicking “Browse” and locating your file or by  

dragging and dropping your file into the appropriate box. If the file you try to upload is unaccepted, you will be prompted to 
re-upload the file. Files must have less than 1,500 locations and be smaller than 5 MB.

b. Click next. Pro will check each column of your uploaded template to make sure it matches system requirements. Pro will  
display a message with any errors. If errors appear, you must fix the original file and re-upload it into Pro by following the 
steps above.

Step 2: Add additional attributes
a. On the second step of the upload process, you will have the option to add additional attributes to the location. Only complete 

these fields if the information is also in your template – all information must match the template you are uploading exactly. 
Once complete, click “Next.”

http://gfw.blog.s3.amazonaws.com/Training%20Guides/GFW%20Pro%20Tutorials/palmoilgeneric_template_shape.zip
https://support.esri.com/en/technical-article/000005588
http://pro.arcgis.com/en/pro-app/tool-reference/appendices/geoprocessing-considerations-for-shapefile-output.htm
https://www.google.com/maps/d/
http://gfw.blog.s3.amazonaws.com/Training%20Guides/GFW%20Pro%20Tutorials/commoditiesgeneric.kml
https://developers.google.com/kml/documentation/


Step 4: Correct and check your data
a. If there are any errors in your file as it uploads, they will appear with a red exclamation point to the left of them. Look for cells 

highlighted red in your locations. Highlighted cells indicate a mistake in a cell. You can hover your mouse over the invalid cell 
and Pro will tell you what format is expected for that cell. 

b. You can update the locations with errors directly on GFW Pro by clicking into the cell that has the error and fixing its  
information. 

c. You can toggle between “Locations with errors” and “All locations” to see which of your locations have errors, where the 
errors are in your locations, and to confirm that an error has been corrected and saved. Locations will move from the  
“Locations with errors” to the “All locations” tab in real time. 

d. You can also download the correct data into a CSV by clicking on the download icon.
e. If you try to move on without fixing the errors, a pop-up asking if you are sure you want to continue will appear. You can 

proceed with the upload process with errors in your list. Any locations with errors will be discarded upon clicking “Submit” to 
upload the list. 

f. Once the validation step is complete, click “Next.”

Step 5: Save your data
a. To save your locations, you can create a new list with a name of your choice or add the locations to an existing list. You can 

only add locations to existing lists with the same commodity template format or with the same commodity type and location 
classification for the generic commodity templates. If you want to return back to a previous step in the upload process, click 
the linked steps on the left-hand side of the screen to review your work. Once complete, click “Submit.”

b. Click “Save.”
c. GFW Pro will then run an analysis of the locations you have added. You will be navigated back to the Location page. A banner 

will appear at the top of the page to indicate that the analysis of your list is in process.  

 

 

d.  You will receive an email when the analysis is complete. You can view the analysis results in the “Locations” tab under the 
“My Lists” section. See more detail on Pro analyses here, or click here to learn how to monitor locations in near real-time.
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Managing Locations and Lists
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Manage Your Lists
In GFW Pro, once you have uploaded a list, you can further manage and make edits to that list from the Locations landing page.
1. Use the search bar to easily find a list or folder.
2. In the “Locations” tab, select a list under “My Lists”. 
3. Click the “Update” button to re-analyze a failed list or to update a list with the most recent data.
4. Click the “...” menu to:

a. Diagnostic – view the Forest Change Diagnostic for your list of locations.
b. Map – view your list of locations on the Pro Map View.
c. Download – download your original input file.
d. Share – share your list internally.
        Note: Only Administrators can initiate list sharing. Editors and Viewers can receive shared lists. 

e. Add to folder – manage your list by adding it to a folder. If the list is already in a folder, this action will say 
“Manage.” A list can only be in one folder at a time.

f. Delete – permanently delete failed and active lists from your Pro account.

Folders
In GFW Pro, once you have uploaded two lists, you can use folders to further manage and your lists from the Locations landing 
page. 
1. After uploading your second list, you will see a banner prompting you to organize lists into folders.
2. In the “Locations” tab, select a list under “My Lists”. 
3. Click on the “...” menu on the list you would like to add a folder.
4. Select “Add to folder”. 
5. For you first folder, you will be prompted to create a new folder. For every folder after your first, you will have the option to 

choose between creating a new folder and adding to an existing folder. 
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7. Once a list has been added to a folder, your folders on the locations landing page will appear above your lists. A banner will 
appear indicating that you have added the list to a folder.  
Note: Your list will still appear under “My Lists”, even if it is added to a folder.

7. To move lists from one folder to another or remote the list from a folder, click on the folder then click on the “...” menu of the list 
within the folder.
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4. You will be brought to a table view to edit your selected locations. You can edit them by clicking in the editable fields indicated 
by the pencil icon and changing the information, then clicking “Update.” If there are validation errors, they will show up in red 
and will appear in the “Locations with Errors” tab – you can hover over them for more information. The “Update” button will 
appear disabled if there are validation errors in your list.

1. In the “Locations” tab, click on a list under “My lists.”
2. In the left-hand column, select the rows you would like to edit. If you want to edit all locations, click 

the top left checkbox on the table.
3. Click “Edit” above the table. 

Edit Your Lists
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1. Copy to list: This will copy the edited locations to an existing or new list. The locations will remain unedited in the original list. 
You can only copy locations to other lists with the same template type. See Appendix 2 for a detailed explanation of templates.
a. Select the locations you would like to copy to another list from the List View.
b. Select “Move” above the table, and choose “Copy.”
c. Select the list you want to add the locations to in the drop down, or create a new list.
d. Click “Confirm” in the modal. 

2. Move to list: This will move the edited locations from their original list into another list. Those edited locations will no longer  
appear in their original list. You can only move locations to other lists with the same template type. See Appendix 2 for a  
detailed explanation of templates.
a. Select the locations you would like to move to another list from the List View.
b. Select “Move” above the table.
c. Select the list you want to add the locations to in the drop down.
d. Click “Confirm” in the modal.

 Note: For GFW lists, only copy will be available.

3. GFW Pro will then re-run analysis for the lists. You will be navigated back to the Locations page. A banner will appear at the top 
of the page to indicate that analysis of your list is in process.

4. You will receive an email when the analysis is complete. You can view the analysis results in the “Locations” tab under the “My 
Lists” section. See more detail on Pro analyses here, or click here to learn how to monitor locations in near real-time.

Move or Copy Locations in Your Lists

Delete Locations in Your Lists
1. To delete locations, click the checkboxes next to the locations you would like to delete then click “Delete” above the table and 

confirm deletion.
2. GFW Pro will then re-run analysis for the lists. You will be navigated back to the Locations page. A banner will appear at the top 

of the page to indicate that analysis of your list is in process.
3. You will receive an email when the analysis is complete. You can view the analysis results in the “Locations” tab under the “My 

Lists” section. See more detail on Pro analyses here, or click here to learn how to monitor locations in near real-time.
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• The two larger lists will prompt you to filter the locations before arriving to the list view.
          -      Administrative Areas: You will be prompted to select a country. You will also have the option to select states and 
                 sub-states in order to filter the list further. Click “Update Values.” If you want to edit your selections, click “Filter” in the
       upper right corner. 
          -      Protected Areas: You will be prompted to filter the results by country. You can also filter further by state, substate, 
                 designation type (type of protected area) and designation (specific protected area). Click “Update Values.” If you want to 
                 edit your selections, click “Filter” in the upper right corner.

• Once you arrive at the desired list view, follow the Copy Locations workflow to save a GFW list, or a subset of locations, to 
your own profile to analyze and return to later. 

Global Forest Watch Lists
There are five GFW lists that are available for use in GFW Pro. These lists represent datasets selected or created by the GFW team at 
WRI. You can use these lists to create your own lists. 

• Administrative Areas: All countries, states, and sub-states worldwide
• Oil Palm Concessions: Oil palm concessions in Brunei, Cameroon, Indonesia, Liberia, Malaysia, Papua New Guinea, Republic of 

Congo, and Solomon Islands

The five GFW lists have slight differences in how they function in Pro.
• When you click on the following three lists, all locations will appear in the list view. You can then select one or all locations to 

view pre-calculated analyses, or see the map view:
     -     Oil Palm Concessions
     -     Palm Oil Mills
     -     RSPO Palm Concessions

• Palm Oil Mills: The industry standard of global 
palm oil mills

• Protected Areas: Legally protected (such as 
national parks and wildlife reserves) or managed 
areas for conservation from the World Database 
on Protected Areas. Protected Areas cannot 
be downloaded outside GFW Pro due to usage 
restrictions

• RSPO Palm Oil Concessions: Palm Oil concessions 
certified by the Roundtable on Sustainable Palm 
Oil. RSPO Concessions cannot be downloaded 
outside GFW Pro due to usage restrictions



Analyzing Locations and Lists



Forest Change: List View and Diagnostic

Forest Change List View
Pro can analyze Forest Change for any location in the application.
1. To view Forest Change analyses, click the “Locations” tab, look for “My Lists,” and click on a list. A table will load.
2. The two analysis views – forest change and commodity risk – can be selected in the drop-down next to “Views” above the table. 

Forest change is the default view. 
                Note: Commodity Risk analyses are available for the Global Forest Watch-managed Universal Mill List, as well as palm oil mill and palm oil 

                 generic templates. See instructions about Commodity Risk analyses here.

GFW Pro allows you to view Forest Change information for locations in your commodity and investment lists. Before 
viewing Forest Change data, you will need to first upload locations (for instructions, click here, and for more information 
about the different templates, see Appendix 2 on page thirty-three and Appendix 3 on page thirty-four). Each uploaded 
location or list of locations must first be processed by Pro. Please upload your locations in advance before you intend to 
use the analyses. Upload processing time can take anywhere between four and 24 hours depending on the list size and 
the template type. You will receive an email confirmation that processing is complete, and your list will appear with the 
label “Analyzing” and will not be clickable in the “Locations” tab. Then proceed with the following tutorial.

GFW Pro offers two types of analysis: Forest Change and Commodity Risk. 

 

See instructions below for how to analyze your locations using Pro. 

 Forest Change analyses show where tree cover loss occurred in your locations, and highlight 
 loss that occurred on some of the most frequently referenced sensitive forest areas in 
 deforestation policies. 
 Commodity Risk analyses illustrate the risk that a palm oil mill is associated with deforestation.

NOTE: GFW Pro is compatible with Google Chrome, Mozilla Firefox and Microsoft Edge. 
You must use one of these browsers in order to access Pro.!

3.    By default, the table displays information about the size of your location, commodity type, geographic location and area of tree 
       cover within your locations. On the far right, the table also shows information about tree cover loss. See the total amount of loss 
       after 2000, then the amount of loss in that period on protected areas and primary forest.
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5.    You can filter the table by clicking “Select filters” then selecting and applying your preferred filters. Once complete, click “Apply 
       filters.” To see applied filters, you can hover over the filters icon; and to clear filters, you can click the “x” next to the filters icon.

6.    You can sort each column in the list view by clicking the column header. Click again to switch between sorting numbers from 
       smallest to largest, letters from A-Z / Z-A, and dates based on date, month and year from earliest to latest or latest to earliest.
7.     Click “View map” above the table to see your list location(s) on the map view. 
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8.    Updated datasets will be available periodically. You will receive an email from the GFW Pro Support team when a new dataset is  
       available. To update your locations in a list with the latest data:
        a.     Click the “Update” button and confirm the list update.
        b.     You will receive an email notification that analysis has begun with the latest-available data on your location and list. Your list will  
 not be available while analysis is processing.
        c.  You will receive a second email notification when analysis finishes and your list is available.
        d.     You can click “Update” on a failed list on the Locations landing page, and click OK. The list will re-process. 
                Note: The update list functionality is available on all list views, including Commodity Risk .

4.    To view additional columns of data uploaded in your template, click “Select Columns.”  Then check the box next to any additional 
       fields you would like to see. Scroll right in the table to see the additional columns. To hide the columns, click “Select Columns,” and 
       un-check column names you would like to hide. You can also select or deselect all columns at once.



Forest Change Diagnostic
From the Forest Change list view, you can run the Diagnostic in two ways: 

• Analyze all locations in your list by clicking the check box at the top left corner of the table.
• Analyze a single location in your list by clicking the check box next to a single location in your list.

               Note: You currently can run a diagnostic analysis only on one location or on the whole list.

1.     Go to the top of the table where you will see an icon labeled “Diagnostic.” You cannot click on this icon until you have 
       selected either one location or all locations in your list. Click “Diagnostic.”
2.    The diagnostic will appear on the page.

• At the top you will see historic characteristics related to your location/s, as well as a map of your selected location/s. Click 
the map to see your locations in Pro’s Map view.

• The rest of the page displays graphs and analyses related to Forest Change in your list, including forest loss in sensitive 
areas and loss over time.

 i.   Customize the data in the bar charts by selecting Tree Cover Loss and/or one sub-category in the list of datasets next 
      to the charts.
 ii.   Drag the time sliders under each chart to change the years shown.
• Regional panels will appear for locations in Southeast Asia and South America with datasets relevant to those regions. 
• For more information about any component of the page, click the “i” info icons.

3.    At the top right, under the map, you can generate a printable PDF of the page by clicking on “Report.” You can also download all 
       data on the page as CSV files by clicking “Download.” 

layer selection

time slider
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Commodity Risk: List View and Diagnostic - Palm Oil
GFW Pro allows you to view the risk that a palm oil mill is associated with deforestation. Commodity Risk Analysis is 
available for palm oil mill and palm oil generic commodity templates. For more information about the different templates, 
see Appendix 2 on page thirty-three and Appendix 3 on page thirty-four.

1. To view Commodity Risk analyses on your uploaded locations, click the “Locations” tab, look for “My Lists” and click on a palm oil 
mill or palm oil generic list. A table will load.

2. The two analysis views – forest change and commodity risk – can be selected in the drop-down next to “Views” above the table. 
Click “Commodity risk.” 

3. The table will now display information about the risk level associated with threats to forested landscapes and values of forested 
landscapes within a 50 km radius around each of your mills. The first column, “T+V,” shows a combined risk indicator for both  
threats and values called the overall Mill Priority Level. That level is the result of running a palm oil mill through the PALM Risk 
Tool, which you can learn more about here. There are three risk levels: low, medium and high. 
              For more information about threats and values, click on the “i” information icons that appear in Pro next to the analysis.

4.    To view additional columns, click “Select Columns.” Then click the check box next to any additional fields you would like to see. 
       Scroll right in the table to see the additional columns. To hide the columns, click “Select Columns” and un-check column names 
       you would like to hide. You can also select and deselect all columns at once.
5.   You can filter the table by clicking “Select filters” then selecting and applying your preferred filters. Once complete, click “Apply 
      filters.” To see applied filters, you can hover over the filters icon; and to clear filters, you can click the “x” next to the filters icon.

Commodity Risk: List View

Before viewing Commodity Risk on your locations, you will need to upload your palm oil mill or palm oil generic list (for 
instructions on uploading locations, click here). Each uploaded location or list of locations must first be processed by 
Pro. Please upload your locations in advance before you intend to use the analyses. Upload time can take anywhere  
between four and 24 hours depending on the list size and on the template type. You will receive an email confirmation 
that processing is complete, and your list will appear with the label “Analyzing” and will not be clickable in the  
“Locations” tab. Then proceed with the following tutorial.

Alternatively, you can select a subset of mills in the Universal Mill List, available in “Global 
Forest Watch Lists” on the Locations landing page. The Commodity Risk analysis will automatically start to process for 
the Universal Mill List Location/s selected (as above).

6.    You can sort each column in the list view by clicking each column header. Click to switch between sorting numbers from  
       smallest to largest, letters from A-Z / Z-A, and dates from January – December / December – January. 
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https://youtu.be/-c3HhIBch0E


Commodity Risk: Diagnostic
1. From the Commodity Risk list view, you can run the Diagnostic in two ways: 

 
 

2. Go to the top center of the page where you will see an icon labeled “Diagnostic.” You cannot click on this icon until you have select-
ed either one location or all list locations. Click “Diagnostic.”

3. The diagnostic will appear on the page.

• Analyze all locations in your list by clicking the checkbox next to “Location name.”
• Analyze one location in your list by clicking the check box next to only one location in your list.

               Note: You cannot run a Diagnostic for more than one selected location in this version of Pro due to programming limitations. 

• At the top are historic characteristics related to your location/s, as well as a map of your 
selected location/s. Click the map to see your locations in Pro’s Map view.

• Different information is available depending on whether you run your diagnostic analysis 
on your whole list, or on one location within a list.

• For more information about any component of the page, click the “i” info bubble icons. 
• At the top right, under the map, you can generate a printable PDF of the page by clicking 

on “Report.” You can also download all data on the page into a CSV by clicking “Download.” 
• Under the map to the left, you can also toggle to the Forest Change diagnostic.

When you run a diagnostic on 
all locations, you can view:

• Trends in deforestation
• PALM Risk Analysis Table

When you run a diagnostic on 
one location, you can view:

• Mill Priority Summary
• Mill Priority History
• Palm Risk Analysis
• Location Details
• Trends in Deforestation

View data by “amount” or “risk level”

Download data 
into a CSV

Click the “i” for more information

Generate a 
printable PDF

Toggle to “forest 
change” diagnostic
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Sharing and Exporting Lists



Internal Sharing

To share lists with other users in your organization, use Internal Sharing. To share lists outside your organization, use the 
Export Lists feature. 

1. From the Locations landing page, click on the list you want to share.
2. Click “Share” on the upper right-hand side of the screen. 

   Note: Only Administrators can initiate list sharing. Editors and Viewers can receive shared lists. 

 
 
 
 
 
 
 
 
 
 

3. Select who from your organization you would like to share the list with from the drop-down button. Once selected, click “Add 
User”. 
   Note: Lists can only be shared with others within your organization.

4. Click “OK”, confirming that you want to share the list. 
 
 
 
 
 

5. Once confirmed, the user you shared the list with will appear in the shared users list with a timestamp indicating when the list 
share occurred. 

6. To stop sharing a list with someone, navigate back to “Share”, click the “X” next to their name then click “OK” to confirm. 
   Note: If you make any updates or edits to your list, the list will automatically update for all recipients. 

 
 
 

User 1. Please confirm by pressing on
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1. Once a list is shared with someone, a “Shared” icon list will next to the list name on the Locations landing page. Recipients will 
have a complete view of the location information, but cannot update, edit or re-share the list internally. Recipients can, however, 
download list results and export a CSV or Shapefile list template. 
   Note: If the person who owns the list makes any updates or edits, the list will automatically update for all recipients. 

Receive Shared Lists

Export Lists
1. From the Locations landing page, click on the list you want to export.
2. Click the “Download” button above the table. From here, you can choose whether you want to export “Results, “CSV” or “Shapefile.” 

 
 
 
 
 

        a.     “Results” will export as a CSV containing analysis results. The exported CSV cannot be uploaded into GFW Pro because it does not  
  include latitude and longitude coordinates. 
        b.     “CSV” will export a CSV that can be uploaded into GFW Pro because it does include latitude and longitude coordinates. 
        c.  “Shapefile” will export a shapefile that can be uploaded into GFW Pro.  
            Note: If a list was originally uploaded as a shapefile, please export that list as a shapefile. Analysis results may differ iff a shapefile is uploaded  

            then later exported as a CSV. 

            Note: Protected Areas and RSPO Palm Concessions GFW lists cannot be downloaded due to usage restrictions. Administrative Areas must be  

            filtered and edited into a new list to be downloaded. 
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         Note: The shared icon will only appear for the user with whom the list was shared. The user who shared the list will not see an icon next to the 
          shared list. 



Using the Dashboard
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The GFW Pro dashboard allows you to prioritize areas, quickly identify problem areas and visually display alerts that cor-
respond with your data. Learn more about near real-time monitoring in GFW Pro here.

1. Click on the “Dashboard” tab in the upper left.
2. In the upper left of the dashboard, click “Show 

lists,” and select the list you want to view on 
the map. 
 Note: It may take several minutes for your locations  
    to load on the map.

There are several ways to use the Dashboard map once your locations have loaded. 

https://youtu.be/OcbsHIy_I7o
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Alerts Introduction
• In the upper left, select GLAD 

deforestation alerts or VIIRS fire alerts 
to display on the map.

• In the upper right, adjust the 
timeframe. For GLAD alerts, you can 
choose to view alerts from the last 
week, month, quarter or year. For 
VIIRS alerts, you can view alerts from 
a day or a week. 

GLAD alerts
• Week: shows a week’s worth of deforestation alerts. Weekly alerts update every 

Wednesday.

• Month: shows alerts from the last four weeks. Monthly alerts update every 

Wednesday.

• Quarter: shows alerts from the past three months. Quarterly alerts update every 

month.

• Year: shows alerts from the past twelve months. Yearly alerts update every month.
VIIRS alerts

• Day: shows fire alerts from the past day. Daily alerts update once per day.

• Week: shows alerts from the past week. Weekly alerts update daily.

See Your Alerts
• The size of the alert circles shows how many locations are in a given area relative to the rest of the list. For example, if 30 

locations are in Brazil out of 100 locations in a list, Brazil will have the second-largest circle out of four. 
   -     Hover over the key below the map to see the percentage of total list locations that corresponds with each bubble size.

• The color of the alert 
circles corresponds to 
the density of alerts in 
or around a location.

Grey: 
no coverage 
by dataset 
or error

Green: 
no alerts or low 
alert density

Yellow: 
medium 
alert density

Orange: 
high alert 
density



• Click on alert bubbles to zoom in on the map. Different zoom levels show different numbers of alerts.

Default view: global zoom
shows one bubble per 
country

Next level: country zoom
shows one bubble per state

Next level: state zoom
shows one bubble per 
sub-state

Final level: sub-state zoom
shows each individual alert 
as its own bubble
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• At the bottom of the dashboard page is an “Alerts Summary.” The “Alerts History” graph displays past alerts based on the alert 
dataset and time period selected. 
   -     “Total Locations” shows the number of locations in your list covered by the alert dataset you selected. For example, GLAD  
         deforestation alerts only cover a limited number of countries worldwide, so only locations in those countries would  
         appear in the “Total Locations” field. Locations in other countries will appear as grey bubbles, indicating no available data. 
   -     “Locations w/ Alerts” counts the number of locations that have alerts with coverage by the selected alert dataset. 
   -     “% of all locations” shows the percentage of the total number of locations in your list with alerts. 
   -     “Alerts” counts the number of alerts appearing on your list locations. 
   -     The total number of alerts appearing in your Alerts Summary section may differ from the sum total of alerts in the Alerts  
         Location Level CSV. The Dashboard Alerts Summary section dissolves all list locations to remove any overlapping locations  
         or duplicated alerts. The Alerts Location Level CSV counts all alerts present. 
   -     Some locations will display “0” or “NA” alert results. Pro will display an “NA” alert result if your locations are in an area not  
         covered by GLAD and/or VIIRS. Pro will display a “0” alert result if your locations are covered by GLAD and/or VIIRS, but a)  
         Data is not yet available for the selected time period and/or b) No alerts occurred during the selected time period. 

Note: Some large uploaded locations (for example, a  

palm oil mill with a 50 KM radius) can cross into  

multiple sub-states or states - especially in small  

countries like Paraguay. Each of the sub-states or states 

within the boundaries of your location will be represented 

by a circle. However, only one sub-state or state closest to 

the center of your location will display a location number. 

The other states or sub-states will appear as circles with  

“0 locations,” to avoid double counting locations, while  

still displaying any potential alerts within the boundaries  

of your location.

• You can load your alerts on the map view 
by clicking the “View Map” icon in the upper 
right of the page. Navigate back to the 
Dashboard by clicking the linked list name  
at the top of the page. 

See Your Alerts on the Map View



Map View



View Uploaded Lists
1. Click the “Show Lists” tab.  

 
 
 
 
 
 
 
 
 
 

2. Click on the list you want to view. It will automatically load on the map. 
            Note: If the locations on a list are global, GFW Pro will set the map to a global view. From here, you can zoom in on specific locations. If  

            locations are specific to a country or region, GFW Pro will set the map to a view of that area. 

           
Turn Data Layers On and Off

1. Turn data layers on and off by hovering over a data category (e.g., “Forest Change”) and clicking the button to the left of the data 
layer you want to add or remove from the map view. 
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                Note: “Region and Country Data” offers data layers specific  

     to individual countries and regions. You can use the search  

     function in that category to quickly search for your country  

     of interest. 

Change the Basemap
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1. Click on the basemap tab.
2. Click on the list you want to view. It will automatically load on the map. 

            Note: If the locations on a list are global, GFW Pro will set the map to a global view. From here, you can zoom in on specific locations. If  

     locations are specific to a country or region, GFW Pro will set the map to a view of that area. 

        a.     You can also remove data layers from the map view by 
 clicking the “X” next to the data layer you want to remove on  
 the data panel. Alternatively, click the eye icon to the left of  
 each layer name to hide (or show) that layer visualization  
 without turning the layer off.



Conduct an Analysis

1. There are three ways to conduct an analysis on GFW Pro’s map. In order to conduct an analysis, you must have a “Forest Change” 
layer turned on.  
        a.     Click on a shape on the map from your list and click “Analyze” to perform the analysis. You can view the analysis results 
         in the analysis tab. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 b.     Draw a shape on the map that surrounds the area you want to analyze. Click “Start Drawing” on the analysis tab to  
        get started; then click on the map, move the mouse, single-click to create points in the polygon, then double-click to  
        form your desired shape. Once the shape is fully connected, the analysis will be performed.   
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c.     Click “Country or Region” on the analysis tab, then click on the “Select a 
        Country” drop-down and select the country you would like to analyze.  
        Once selected, the analysis will perform and you can choose a state or  
        province within that country to analyze. 

1. 
2. 
3. Clicking the “Download Data” button will link you to the University of Maryland’s  

underlying dataset for download.
4. Clicking “Discard Analysis” will clear the analysis function and allow you to start over.  

 

1. 
2. When an analysis is performed, you can click “Add New Location” to add the  

selected location to a new list or an existing list in your Pro account. 
 
 
 
 

Additional Features
1. The search button allows you to search by address or place, coordinates, or decimal degrees. You can also conduct a search in 

specific lists (e.g., Universal Mill List) by clicking on the drop-down arrow on the search bar.   
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1. 
2. When an analysis is performed, you can click “Add New Location” to add the selected location to a new list or an existing list in 

your Pro account. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. The time slider narrows the data visualized on the map as well as the years that your analyses include by allowing you to select a 
range of years. 
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Upload Shapefiles and KML Data



Upload Shapefiles
Shapefiles are one of the geospatial file formats that can be used to upload data into GFW Pro. To create and edit  
shapefiles, use GIS software such as ArcGIS Desktop or QGIS. 

Find out more about how ArcGIS Desktop for Windows can be purchased, installed and other information.  

QGIS is free and can be used both on Windows and Macs. Download QGIS software.  
This section describes the various steps users may need to complete to get shapefiles in the right format to get uploaded into GFW Pro. 
Both new GIS users and GIS analysts should review the steps and additional detail below to minimize potential GFW Pro data upload 
errors. For additional help, review the resource links listed throughout the tutorial. 

1. Use Proper Shapefile Geometry (Point or Polygon). 

2. Ensure the Data is Located on Land. 

3. Fix Shapefile Topology (Data Quality) if Needed.

4. Use the Required Field Names for the Template.

5. Use the Appropriate Values in Data for Each Field.

6. Ensure the Number of Polygons or Points is Less Than 1500. 

7. Ensure that the File Size of the Shapefile is Less than 5MB/5000KB.

8. Use Simple Shapefile File Names (No Diacritical Marks). 

9. Ensure that Shapefiles Include the Following Files: .SHP, .SHX, .PRJ, .DBF. 

10. Zip Shapefiles into One Folder.

11. Do You Have Too Many Lists to Upload? Try Dissolving the Shapefiles.  

The shapefile uploaded into GFW Pro must either be a point or polygon geometry. The shapefiles cannot be line geometry. A point 
shapefile represents an exact location with a latitude and longitude value. A polygon shapefile represents a location that has an area 
or shape.  
ArcGIS:

• To check the geometry type, right click on the input shapefile in the ArcGIS table of contents and open the attribute table. The 
Shape field should say either polygon or point for all rows (see visuals below).  
 
Point shapefile attribute table examples: 
 
 
Polygon shapefile attribute table example: 

• In the upper right, adjust the timeframe. For GLAD alerts, you can choose to view alerts from the last week, month, quarter or 
year. For VIIRS alerts, you can view alerts from a day or a week. 

Related tutorials are available on ArcGIS Desktop and ArcGIS Pro.
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Use Proper Shapefile Geometry (Point or Polygon)

https://www.esri.com/en-us/store/arcgis-desktop
https://qgis.org/en/site/forusers/download.html
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/editing-fundamentals/creating-polygons-from-lines.htm
http://pro.arcgis.com/en/pro-app/tool-reference/data-management/feature-to-polygon.htm


QGIS:

• In QGIS, right click the input shapefile and open up properties to check the metadata tab, then scroll down to view the geometry 

type (see visuals below).  
 
Point shapefile attribute example: 
 
 
Polygon shapefile attribute example: 

• To convert lines to polygons or points, use feature/line to polygon or feature/line to polygonise tools.

A related tutorial is available on StackExchange. 
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All shapefiles need to be located within land boundaries (not on water) or they may encounter clip to land errors in GFW Pro. 
To check the location of input shapefiles, overlay them with GADM administrative boundaries. GADM data show administrative 
boundaries for countries, states and sub-states around the world.
Download GADM 2.8 country boundary shapefiles for locations here.
Note: Please download GADM version 2.8 and not version 3.6.   
ArcGIS:

• Go to Selection > Select by Location. For selection method, choose selection features from and pick input shapefile. For Source 

layer, pick the GADM boundary for the countries datasets are located in. For spatial selection, pick “intersect the source layer 

feature” and then press OK. 

 

 

 

 

 

• Next, open up the attribute table for shapefile. If any rows are selected, it means that those features are located in the country 
administrative boundary used for the Select by Location tool. If any row isn’t selected, it either means it is located in a different 
country or it is located in the ocean according to the GADM 2.8 boundary database. 

• If data is found to be in the ocean, please edit the location of the problem area (by either updating the latitude/longitude values 
or editing the physical location of the boundaries) or remove the feature from the dataset before uploading it to GFW Pro.

Related tutorials are available on ArcGIS Pro, ArcGIS Desktop, ArcGIS Desktop and StackExchange. 

Ensure the Data is Located on Land

https://gis.stackexchange.com/questions/207463/convert-a-line-to-polygon?rq=1 
https://gadm.org/download_country_v2.html
http://pro.arcgis.com/en/pro-app/help/editing/move-a-feature-to-specified-location.htm
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/creating-new-features/moving-a-feature-by-dragging-it.htm
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/editing-fundamentals/moving-a-vertex-to-a-specific-x-y-location.htm
https://gis.stackexchange.com/questions/175831/editing-x-y-of-point-in-shapefile-using-arcgis-for-desktop
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QGIS:

• Select Vector > Research Tools > Select by Location. Pick input data as the layer to select from and administrative boundary as 

the additional layer. Choose intersects and creating a new selection, then press run.

• Next, open up the attribute table for shapefile. If any rows are selected, it means that those features are located in the country 

administrative boundary used for the Select by Location tool. If any row isn’t selected, it either means it is located in a different 

country or it is located in the ocean according to the GADM 2.8 boundary database.  

 

 

 

 

 

 

 

 

 

 

 

• If data is found to be in the ocean, please edit the location of the problem area (by either updating the latitude/longitude values 

or editing the physical location of the boundaries) or remove the feature from the dataset before uploading to GFW Pro.

Related tutorials are available on QGIS, Harvard and GIS Lounge. 

GIS topology are rules and behaviors that determine how coincident geometric features should function. Common topology issues 
that may occur are overlapping polygons and self-intersecting polygons.
Check out visual examples of common topology errors on ArcGIS Desktop and ArcGIS Resources.
Note: This step may be optional. It is possible that the dataset may still upload to GFW Pro without having to fix topology issues. But if problems 

uploading data to GFW Pro occur, consider fixing the topology.  
ArcGIS:

• To check for topology issues, go to ArcToolbox > Data Management > Features > Check Geometry to review possible topology 

errors in shapefile. The output of this function lists possible problematic areas. To fix the geometry, go to ArcToolbox > Data 

Management > Features > Repair Geometry. 

Note: Sometimes the Repair Geometry tool does not repair the topology issues completely. If this happens, consider fixing data manually by editing the 

shapefile and updating the boundaries by editing the shapes (vertices and segments) in the shapefile or removing the problematic polygons or points. 

Fix Shapfile Topology (Data Quality) if Needed

https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html
http://maps.cga.harvard.edu/qgis/edit/vector_points/ 
https://www.gislounge.com/editing-data-mastering-qgis/
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/editing-topology/geodatabase-topology-rules-and-topology-error-fixes.htm
http://resources.arcgis.com/en/help/main/10.2/01mm/pdf/topology_rules_poster.pdf
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A tutorial on how to edit verticies and segments of shapefiles in ArcGIS is available on ArcGIS Desktop.

Alternative tutorials on possible solutions to fix topology issues in shapefiles include: 

• Dissolve boundaries via ArcGIS Pro.

 Note: The dissolve method may be limited by the complexity of data. If the dataset has very complicated boundaries and/or is large in size,  

 there may be issues with dissolving.

• Convert polygon to raster via ArcGIS Pro and convert raster back to polygon via ArcGIS Pro.
• Convert shapefile to geodatabase, create geodatabase topology and convert back to shapefile via ArcGIS Desktop. 

QGIS:

• To check the topology of data, go to Vector > Geometry Tools > Check Validity. Read more information on StackExchange and 

Geodose. 

• Alternatively, try this method to check the topology: 

 -      Run the Geometry Checker Plugin. Read more information on QGIS.

• To clean the data, either fix it manually by editing the shapefile or try running some of the following tools:

 -      v.clean - Read more information on Geodose, StackExchange and Faunalia. 

 Note: If none of the above methods work to fix the geometry, consider fixing data manually by editing the shapefile and updating the  

 boundaries by editing the shapes (vertices and segments) in the shapefile, or removing the problematic polygons or points.

Read more information on how to edit vertices and segments of shapefiles in QGIS on QGIS. 

There are different templates for various commodities, including soy, cocoa, palm oil, beef, cattle and investments. Each of these 
templates requires different fields for successful upload into GFW Pro. Thus, users must customize the fields in their datasets to 
include the required fields depending on the templates used. Most of the templates include fields that must have specific values 
and some fields that can be left blank. Users can also include up to 3 extra attribute fields of their own. If extra non-required fields 
are included in the shapefile, GFW Pro will include the first 3 of these fields during the upload as the 3 extra attribute fields. Any 
remaining extra non-required fields will be ignored during the GFW Pro data upload.

Note: For an explanation of which GFW Pro template to select, click here. Then download a sample .zip shapefile of that template here. 

Review the commodity template needed and add ALL the fields listed in the corresponding template in shapefile. If every field is not 

included, the dataset will not successfully upload into GFW Pro. 

There are two ways to add the required template fields to the shapefiles (both methods are described below): 

1. Add Required Fields by Merging Pro Template Shapefile to Region of Interest Shapefile 

2. Add Fields Manually with Right Field Type 

Use the Required Field Names for the Template

http://desktop.arcgis.com/en/arcmap/10.3/manage-data/editing-existing-features/editing-vertices-and-segments.htm
http://pro.arcgis.com/en/pro-app/tool-reference/data-management/dissolve.htm
http://pro.arcgis.com/en/pro-app/tool-reference/conversion/polygon-to-raster.htm
http://pro.arcgis.com/en/pro-app/tool-reference/conversion/raster-to-polygon.htm
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/editing-topology/geodatabase-topology-rules-and-topology-error-fixes.htm
https://gis.stackexchange.com/questions/259256/qgis-invalid-geometry-even-after-using-validity-checker-and-v-clean
https://www.geodose.com/2017/09/how-to-check-topology-error-in-qgis.html
https://docs.qgis.org/2.14/en/docs/user_manual/plugins/plugins_geometry_checker.html
https://www.geodose.com/2017/10/how-to-clean-topology-error-in-qgis.html
https://gis.stackexchange.com/questions/259256/qgis-invalid-geometry-even-after-using-validity-checker-and-v-clean
https://faunaliagis.wordpress.com/2013/08/14/bad-bad-polygon-fixing-invalid-geometries-with-quantum-gis/
https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html
https://d1ps9kreypzu9a.cloudfront.net/Training%20Guides/GFW%20Pro%20Tutorials/GFW_Pro_UserGuide.pdf
https://drive.google.com/drive/folders/1wcZZIO9U2D9NJ7RE8AjlEtfbR5wZ4Ykc?usp=sharing 
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ArcGIS:
Add Required Fields by Merging Pro Template Shapefile to Region of Interest Shapefile

• First, download the shapefile template of your choice from GFW Pro and add it to ArcGIS software.

• To merge GFW Pro template shapefile to region of interest shapefile, select Geoprocessing > Merge and pick the GFW Pro 

shapefile (with the right fields) and region of interest shapefile as inputs to merge into one shapefile. Then, fill out the mandatory 

and optional fields as needed for each of the rows in shapefile. 

Deleting Extra Rows

• Don’t forget to delete the original sample polygon that was listed in the Pro shapefile template and not included in original 

shapefile. To delete the sample row, select the sample row in the attribute table and go to the Database Management Toolbox -> 

Features > Delete Features. (Make sure the sample row that needs to be deleted is selected or this function will delete ALL the 

rows).

Deleting Extra Fields

• If needed, delete the extra fields that were in original shapefile (unless these extra fields are being used as the 3 extra attribute 

fields). Delete fields by right clicking the field in the attribute table and selecting delete field. (Warning: this cannot be undone).

• Please do not try to delete the OID/FID and Shape field. Required fields cannot be deleted. Here is a workaround if there is a 

need to remove a required field from shapefile. 

For more information about merging, deleting rows and deleting fields can be found on ArcGIS Pro, ArcGIS Desktop and ArcGIS 

Desktop. 

QGIS:

Add Required Fields by Merging Pro Template Shapefile to Region of Interest Shapefile

• First, download the shapefile template for commodity and add it to QGIS software.  

• To merge GFW Pro template shapefile to region of interest shapefile, go to Vector > Data Management Tools > Merge Shapefile to 

One.  

Deleting Extra Rows

• Toggle Editing - > Select Row -> Use Delete Selected Tool -> click Toggle Editing again to turn off. 

Deleting Extra Fields

• If needed, delete the extra fields that were in original shapefile (unless these extra fields are being used as the 3 extra attribute 

fields). Delete fields by going to: Toggle Editing > Delete Column > select the fields to delete > click Toggle Editing again to turn 

off. 

• Please do not try to delete the OID/FID and Shape field. Required fields cannot be deleted.  

For more information about merging, deleting rows and deleting fields can be found on Duke, QGIS and StackExchange.

 

https://support.esri.com/en/technical-article/000014937
http://pro.arcgis.com/en/pro-app/tool-reference/data-management/merge.htm 
http://desktop.arcgis.com/en/arcmap/10.3/tools/data-management-toolbox/delete-features.htm 
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/tables/deleting-fields.htm 
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/tables/deleting-fields.htm 
 https://guides.library.duke.edu/QGIS/Merge 
https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html#deleting-selected-features 
https://gis.stackexchange.com/questions/12329/how-to-delete-fields-in-qgis 
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Add Fields Manually with Right Field Type

This section goes over how to add the fields required from commodity template manually to shapefile. 

Before getting started in GIS software, remember the following guidelines:

Field Order Creation

The order that the fields are created in does not matter. Just make sure to include all the fields listed, whether they will be filled out  

or not.

• Mandatory fields and optional fields: Please fill out all mandatory fields as described in the template requirements. Leave the 

optional fields blank as needed, but include the optional field column in the shapefile.

Field Names

Type in the field names EXACTLY how they are shown in the template. Use the same case (uppercase/lowercase) and spelling in the 

template. 

Note: For shapefile field names, only the first 10 characters will be used. Spaces are not allowed in shapefile field names. Use underscores (_) to 

replace spaces for shapefile field names. So “Location Name” will be “Location_N”.

• Custom fields: Create up to 3 custom fields inside shapefile with any field name as long as they do not use any reserved or 

required field names from the template. They must also follow shapefile field name protocol explained on Esri and ArcGIS 

Desktop.

Field Types

Please make sure that fields are created with the right field type as listed in the commodity template spreadsheet (ex. string, floating 

number, integer, date, ex.)

• For string fields, choose text.

• For latitude/longitude fields (for point shapefiles only), choose float.

• For double fields, choose double.

• For date fields, choose date. 

 Note: If the date fields will be left blank, please choose TEXT for the date field. If not, errors may be shown when uploading data to GFW Pro.

• Latitude/longitude/analysis area/analysis radius fields:

 -      Polygon shapefiles do not need the Latitude, Longitude, Analysis Area and Analysis Radius fields.

 -      Point shapefiles need to include the Latitude, Longitude, Analysis Area and Analysis Radius fields. 

 -      The Latitude and Longitude fields must be in Decimal degrees (ex. 80.4383). 

 -      The Analysis area should be in Ha. The Analysis Radius field should be in km. For each row, either need to fill out analysis 

         area or analysis radius. Do not fill out both columns for each for in the point shapefile. 

ArcGIS:

How to Add a New Field in a Shapefile

Open the attribute table of shapefile> Table Options > Add Field. Enter the field name following the guidelines listed above and select 

the right data type. Check ArcGIS Pro for more information.

 

https://support.esri.com/en/technical-article/000005588 
https://desktop.arcgis.com/en/arcmap/latest/manage-data/tables/fundamentals-of-adding-and-deleting-fields.htm#GUID-8E190093-8F8F-4132-AF4F-B0C9220F76B3 
https://desktop.arcgis.com/en/arcmap/latest/manage-data/tables/fundamentals-of-adding-and-deleting-fields.htm#GUID-8E190093-8F8F-4132-AF4F-B0C9220F76B3 
http://pro.arcgis.com/en/pro-app/tool-reference/data-management/add-field.htm 
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Delete Fields

Delete fields by right clicking the field in the attribute table and selecting Delete Field. (Warning: this cannot be undone). 

Note: Please do not try to delete the OID/FID and Shape field.

Note: Required fields cannot be deleted. Here is a workaround if there is a need to remove a required field from shapefile.

More information about deleting fields can be found on ArcGIS Desktop. 

QGIS:

How to Add a New Field in a Shapefile 

Toggle Editing > Field Calculator > check Create New Field > click Toggle Editing again to turn off. Check QGIS and StackExchange 

for more information. 

Remember to delete any fields not listed in commodity template, unless they are being used as custom attribute fields. Delete the 

extra fields that were in original shapefile (unless they are being used as the 3 extra attribute fields).

Delete Fields

Toggle Editing > Delete Column > select the fields that need to be deleted > click Toggle Editing again to turn off. Check 

StackExchange for more information. 

Please make sure the values entered in fields meet the requirements for the corresponding field as listed in the template. Certain 

fields will only accept certain values in GFW Pro. If a field only accepts certain values, please make sure that correct spelling is used. 

Note: Click here for an explanation of which GFW Pro template to select. Then download a sample .zip shapefile of that template here.

ArcGIS:

How to Update Field Values in Field in Attribute Table

If fields were created through a merge/join, review the following tutorials for updating field values by copying values from other 

fields using field calculator: StackExchange, Esri, GIS Lounge and ArcGIS Desktop.

If fields were created manually, review the following tutorials for updating field values using an edit session: ArcGIS Desktop and 

ArcGIS Desktop.

QGIS:

How to Update Field Values in Field in Attribute Table

If fields were created through a merge/join, review the following tutorials for updating field values by copying values from other 

fields using field calculator: QGIS, QGIS and StackExchange. 

If fields were created manually, review the following tutorials for updating field values using an edit session: QGIS and Biplov 

Bhandari.

Use the Appropriate Values in Data for Each Field

https://support.esri.com/en/technical-article/000014937
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/tables/deleting-fields.htm 
https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/attribute_table.html#using-the-field-calculator 
https://gis.stackexchange.com/questions/95077/qgis-how-to-add-string-field 
https://gis.stackexchange.com/questions/12329/how-to-delete-fields-in-qgis 
https://d1ps9kreypzu9a.cloudfront.net/Training%20Guides/GFW%20Pro%20Tutorials/GFW_Pro_UserGuide.pdf
https://drive.google.com/drive/folders/1wcZZIO9U2D9NJ7RE8AjlEtfbR5wZ4Ykc?usp=sharing
https://gis.stackexchange.com/questions/206837/copying-data-from-one-attribute-field-to-another-using-arcgis-field-calculator 
https://www.esri.com/news/arcuser/0405/files/fieldcalc_1.pdf 
https://www.gislounge.com/tips-using-field-calculator-arcgis/ 
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/tables/making-field-calculations-making-simple-field-calc.htm 
http://desktop.arcgis.com/en/arcmap/latest/manage-data/tables/understanding-how-to-edit-values-in-a-table.htm 
http://desktop.arcgis.com/en/arcmap/latest/manage-data/tables/editing-a-value-in-a-table-cell.htm 
https://docs.qgis.org/2.8/en/docs/user_manual/working_with_vector/field_calculator.html 
https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/attribute_table.html 
https://gis.stackexchange.com/questions/279735/adding-text-from-one-field-to-another-in-qgis-attribute-table 
https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/attribute_table.html 
https://biplovbhandari.wordpress.com/2017/11/26/updating-column-name-and-column-value-in-qgis/ 
https://biplovbhandari.wordpress.com/2017/11/26/updating-column-name-and-column-value-in-qgis/ 
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The number of rows in shapefile cannot be more than 1500. If they are more than 1500, split them up into smaller shapefiles 

containing no more than 1500 rows each.  

ArcGIS:

Split Shapefile into Smaller Rows:

• Open the attribute table > select the first 1500 rows > right click shapefile in Table of Contents > Data > Export Data > Export: 

Selected Features > Save As new shapefile. Repeat as needed until all shapefiles contain less than 1500 rows. 

QGIS:

Split Shapefile into Smaller Rows:

• Open the attribute table > select the rows to split > right click shapefile in Table of Contents > Save As > Save Vector Layer As… > 

check Save Only Selected Features > Save As new shapefile. Repeat as needed until all shapefiles contain less than 1500 rows. 

Ensure the Number of Polygons or Points is Less than 1500

Please make sure the size of shapefile is not greater than 5 MB/5000 KB. To check the size of file, view the file in File Explorer and 

look at the size tab. If file is too big, split up shapefile into smaller lists as described in the section above.  

Ensure that the File Size of Shapefile is Less than 5 MB/5000 KB

It is recommended to keep the shapefile file names simple and clean. This includes: 

• Using alphanumeric characters, starting file names with letters.

• No spaces (use underscores instead). 

• No diacritical marks in file names.

Use Simple Shapefile File Names (No Diacritical Marks)

Before shapefiles are zipped, please include the following file types with the SAME file name:

.shp – shapefile, .shx – shape index position, .prj – projection, .dbf – database table

If these files are missing, please recreate shapefile. Additional file types might be listed as well such as .cpg, .sbn, .sbx, but they are 

optional. However, please do not delete them if they are included with shapefile. They should be included in the zipped folder (see 

next section for suggestions on how to zip shapefiles).

Use Simple Shapefile File Names (No Diacritical Marks)
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Shapefiles need to be compressed into a zipped folder before uploading to GFW Pro. 

Go to the folder where the shapefiles are stored on computer. Select all the required shapefile files needed for the zip. They should 

all have the same file name. To create a zipped folder, right click the selection (all the required shapefile files), click Send To and then 

press Compress Zipped Folder.  

Zip Shapefiles into One Folder

If there are too many lists to upload, consider merging shapefiles into one shapefile and then dissolving them into smaller lists. 

Remember that the dissolved file needs to be less than 5 MB.  

Locations should not be larger than a 50 km radius, whenever possible. Larger areas, especially with complex geometries, are likely 

to stall or fail during the analysis process. 

Note: If there are issues with the dissolve, split the data even more to make smaller file sizes or continue to work on cleaning the data. See previous 

instructions on how to clean the data. 

ArcGIS:

• Merge shapefiles: Go to Geoprocessing > Merge to select the shapefiles that need to be merged into one file. 

• Dissolve shapefiles: Go to Geoprocessing > Dissolve to dissolve these rows into one row. 

• Splitting Rows: Open the attribute table > select the rows to split > right click shapefile in Table of Contents > Data > Export 

Data > Export: Selected Features > Save As new shapefile. Repeat as needed until all shapefiles dissolve properly. 

QGIS:

• Merge shapefiles: Go to Vector > Data Management Tools > Merge shapefile to one. 

• Dissolve shapefiles: Go to Vector > Data Management Tools > Dissolve. 

• Splitting Rows: Open the attribute table > select the rows to split > right click shapefile in Table of Contents > Save As > Save 

Vector Layer As… > check Save Only Selected Features > Save As new shapefile. Repeat as needed until all shapefiles dissolve 

properly. 

Too Many Lists to Upload? Try Dissolving Shapefiles

ArcGIS:

Shapefile Requirements and Limitations

Shapefile Field Limitations

QGIS:

QGIS Tutorial

QGIS Tutorial (available in various languages)

Resources - Shapefile, ArcGIS and QGIS Tutorials

http://pro.arcgis.com/en/pro-app/tool-reference/appendices/geoprocessing-considerations-for-shapefile-output.htm
https://support.esri.com/en/technical-article/000005588
https://www.qgistutorials.com/en/
https://www.qgis.org/en/site/forusers/trainingmaterial/index.html
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KML stands for keyhole markup language. A zipped version of KML is called KMZ. KMLs are geospatial datasets that can be displayed 

in Earth browser applications like Google Earth. You can upload both polygon area KML or KMZ into GFW Pro.

For more information about KMLs, click here.

For more information about Google Earth, click here.

To display the KML or KMZ, use Google Earth. Download Google Earth here for free.

Notepad++ can also be used to view the KML code. Download Notepad ++ here for free. To view a KMZ file in Notepad++, please 

unzip it to KML first.

How to Open KML/KMZ Files

1. Open KML in Google Earth.

2. Zoom to the extent of the KML.

3. Click on one of the features in KML and it will display the fields and their corresponding values. 

 Note: Lat/Long Decimal Degrees notation – KML/KMZ files show Longitude first and Latitude second. 

How to View KML/KMZ Fields in Google Earth

The following is a checklist to review to make sure that KML/KMZ is in the right format to upload into GFW Pro.

1. Only use polygon or point geometry. Don’t include any images or HTML content in KML/KMZ. Open up the KML/KMZ to examine 

whether it ’s geometry. If it contains line geometry or any extra features such as images or HTML, the KML/KMZ may need to be 

recreated to remove unaccepted features.

2. Ensure the data is located on land. Open up the KML in Google Earth to make sure all of the features are located on land. If not, 

please remove the polygons or points located in the ocean. To delete, right click the feature in the table of contents and press 

delete.

3. Limit each KML/KMZ to 1500 polygons or points. In addition, file size limited to 5 MB/5000 KB. To create a smaller KML/KMZ, 

make copies of KML/KMZ and paste it in Google Earth and delete features until KML/KMZ reaches the required size (less than 5 

MB) and row number (less than 1500 rows) and save as a new KML.

4. The projection of the KML/KMZ needs to be in World Geodetic System 1984 (WGS84). Fortunately, the KML/KMZ files already use 

this projection by default when they are created. 

5. Use the appropriate field names and values for the template downloaded. (See section on How to Edit Field Names and/or 

Values for KMLs below). 

 Note: Click here for an explanation of which GFW Pro template to select. Then download a sample .zip shapefile of that template here.

KML/KMZ Format Checklist

KML/KMZ

https://developers.google.com/kml/
https://www.google.com/earth/
https://www.google.com/earth/download/ge/
https://notepad-plus-plus.org/download/v7.5.9.html
https://d1ps9kreypzu9a.cloudfront.net/Training%20Guides/GFW%20Pro%20Tutorials/GFW_Pro_UserGuide.pdf
https://drive.google.com/drive/folders/1wcZZIO9U2D9NJ7RE8AjlEtfbR5wZ4Ykc?usp=sharing 
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To edit the field names and/or values in a KML, try the following: 

1. Create a Google account or sign into Google Account if user already has one.

2. Visit https://www.google.com/maps/d/.

3. Create a new map.

4. Add layer > Import > Upload KML/KMZ file to map. 

5. Next to the KML/KMZ file name, select the 3 dots. Open data table. 

6. Make changes to field names by renaming in a table or editing attribute values. 

7. When finished, export the layer back to KML. Click the 3 dots next to the name of the map. Select export to KML/KMZ. Select the 

KML file. Download. 

KML/KMZ - How to Edit Field Names and/or Values

If there is a need to use spreadsheets instead of a KML file, complete the following method: 

1. Convert KML to XLSX online using the My Geodata Converter tool.

2. Upload the KML to the site and it will convert it to xlsx. It will contain an x and y field for the longitude(x) and latitude(y) values.

Need to Convert KML File to XLSX or Open it up as a Spreadsheet?

Keyhole Markup Language (KML)

Resources - KML Tutorials

http://www.gmail.com
https://www.google.com/maps/d/
https://mygeodata.cloud/converter/kml-to-xlsx
https://developers.google.com/kml/
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Appendix 1: User Permission Levels

Administrators can:
• View, activate and deactivate users in the organization’s account
• Edit specific account fields and user fields
• Upload and enter locations
• Create lists
• Edit and delete locations associated with all users in the organization’s account
• Create, edit and delete lists created by all users in the organization’s account
• Create custom lists from existing Global Forest Watch lists, such as Administrative Areas, Oil Palm Concessions, Palm Oil Mills, 

Protected Areas and RSPO Oil Palm Concessions
• View diagnostics and dashboard results on all lists within their organization(s)
• View and download activity log

Editors can:
• View and edit their own user information
• Upload and enter locations
• Create lists
• Edit and delete locations that they created
• Edit and delete lists that they created
• Create custom lists from existing Global Forest Watch lists, such as Administrative Areas, Oil Palm Concessions, Palm Oil Mills, 

Protected Areas and RSPO Oil Palm Concessions
• View diagnostics and dashboard results on their lists

Viewers can:
• View and edit their own user information
• View existing Global Forest Watch lists, such as Administrative Areas, Oil Palm Concessions, Palm Oil Mills, Protected Areas and 

RSPO Oil Palm Concessions
• View diagnostics and dashboard results on Global Forest Watch lists or lists shared to the viewer from within their organiza-

tion (functionality to be launched in late 2018 - early 2019). 
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Appendix 2: Selecting the Correct Template

When selecting a template, you will first choose whether you are working with an Investment or Commodity.

Investment: Select for any investment in any commodity type. An investment list can contain multiple commodity types.

Commodity: Commodity templates are designed to capture specific descriptive data for your commodity of choice. Certain analyses 
are only available for specific commodities. Pro recognizes the commodity based on the template you upload.

• Each template you upload is limited to one:
        -     Commodity type
        -     Location classification:
               >      Property: Farm or plantation.
               >      Supply Shed: Sourcing area around a processing facility, storage facility, or collection point
               >      Administrative Area: Any non-property or supply shed area. For example, a country, state, or sub-state.
• For detailed instructions on completing a template, see the Palm Oil Generic example below.
• The templates are:

1. Generic Commodity: Recommended for any commodity not listed in the template drop-down menu.
2. Palm Oil Mill: Recommended only for palm oil mills in the Universal Mill List, since this template requires a universal mill 

list ID for every mill.
3. Palm Oil Plantation: Recommended for palm oil concessions and plantations.
4. Palm Smallholder Farm: Recommended for palm oil smallholder farms.
5. Palm Oil Generic: Recommended for palm oil mills not listed in the Universal Mill List.
6. Soy Silo
7. Soy Farm
8. Soy Generic: Recommended for soy supply chain locations beyond silos and farms.
9. Beef Slaughterhouse
10. Cattle Ranch
11. Cattle Generic
12. Cocoa Farm
13. Cocoa Generic: Recommended for cocoa supply chain locations beyond farms.

Template limitations:
• For the generic commodity template, you must select one commodity for the entire list. For the other commodity templates, 

Pro will automatically populate the commodity as the commodity type that matches that template.
• Location selection
        -      You must select one Location Classification (property, supply shed or administrative area) for the following templates: 
                generic, palm oil generic, soy generic, cattle generic and cocoa generic. 
        -      Pro will automatically populate Location Classification as “supply shed” for the following templates: palm oil mill, soy silo 
                and beef slaughterhouse.
        -      Pro will automatically populate Location Classification as “property” for the following templates: palm oil plantation, palm 
                smallholder farm, soy farm, cattle ranch and cocoa farm.
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Appendix 3: Completing Your Excel Template
1. Open the downloaded Excel template.
2. In the downloaded Excel file, you will see a series of columns to populate with details of your locations.
3. Carefully read the instructions in each cell in rows 2-4. During the upload process, Pro will validate all uploaded locations based on 

the specifications in the Excel template.
• For example, a validation error will occur if you input start and end dates in the format DD-MM-YYYY. As specified, start and 

end dates must be input as MM/DD/YYYY.
4. Reference the template list for guidelines on variations in commodity and location classification selection among the different 

templates.
5. Populate the spreadsheet with data below row 5, then delete the instructional rows (rows 2-4) or pro will not successfully upload 

the file.
6. You must fill out columns A, B, C and (D or E) (location name, latitude, longitude, sourcing radius or sourcing area). Area must be in 

hectares and the radius must be in kilometers. Enter just the digits in the field. All other columns are optional, but may be helpful to 
reference in Pro.

7. You may add up to three optional customizable fields: the last three columns in the template labeled Attribute1, Attribute2, and 
Attribute3.
• Change the column headers to a text name of your choosing.
• Populate the cells below the instructional rows with text. 
• Note: You must re-enter these attribute field names exactly on Step 2 of the locations upload process.  

8. Do not delete any columns from the spreadsheet. If you do not need a particular column, simply leave it blank.
9. When you have completed the Excel sheet, save it to your computer.

Columns A, B and C, plus 
either D or E, are mandatory.

In the last three columns, you 
can add customized fields.
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